A repeater is used to extend the range of wireless coverage. In this mode you cannot configure multiple vlan on repeater access point. It only support single vlan & it has to be on the native vlan. Here is my basic set up to test the repeater functionality.
Repeater only can connect to root access point in Autonomous mode. Vlan 110 is configured as native vlan & assigned to only single SSID created called”WGB”. Under radio interface “station-role repeater” needs to configure to specify it as repeater. If Aironet extensions are disabled (by default it should be enable) you can enable it by using “dot11 extensions aironet” command. Here is the full configuration of repeater AP
hostname AAP3
!
dot11 ssid WGB
vlan 110
authentication open
guest-mode
infrastructure-ssid
!
interface Dot11Radio0
ssid WGB
station-role repeater
!
interface Dot11Radio0.110
encapsulation dot1Q 110 native
bridge-group 1
!
interface GigabitEthernet0.110
encapsulation dot1Q 110 native
bridge-group 1
!
interface BVI1
ip address 10.10.110.103 255.255.255.0
!
ip default-gateway 10.10.110.3
No sepcific configurations at root accesspoint other than “station-role root” under radio interface where repeater is going to associate. I have configured DHCP for repeater client on this root AP & it is not required for repeater functionality.
hostname AAP1
!
ip dhcp excluded-address 10.10.110.1 10.10.110.200
ip dhcp excluded-address 10.10.110.211 10.10.110.255
!
ip dhcp pool REPEATER
network 10.10.110.0 255.255.255.0
default-router 10.10.110.3
domain-name mrn.com
dns-server 192.168.200.1
option 150 ip 10.10.205.20
!
dot11 ssid WGB
vlan 110
authentication open
infrastructure-ssid
!
interface Dot11Radio0
ssid WGB
station-role root
!
interface Dot11Radio0.110
encapsulation dot1Q 110 native
bridge-group 1
!
interface FastEthernet0.110
encapsulation dot1Q 110 native
bridge-group 1
!
interface BVI1
ip address 10.10.110.101 255.255.255.0
!
ip default-gateway 10.10.110.3
Once you do this configuration & your client configured for to connect the WGB SSID you can see these associations by using “show dot11 associations” command in root AP.
AAP1(config)#do sh dot11 ass 802.11 Client Stations on Dot11Radio0: SSID [WGB] : MAC Address IP address Device Name Parent State 001b.d458.e61a 10.10.110.204 Rptr-client SEP001BD458E61A 68ef.bd0f.d95a Assoc 0022.fa94.6858 10.10.110.201 Rptr-client AAP3 68ef.bd0f.d95a Assoc 68ef.bd0f.d95a 10.10.110.103 ap1250-Rptr AAP3 self Assoc
you can align repeater access point antenna with another remote antenna using “dot11 dot11radio [0|1] antenna-alignment timeout” command in global mode. Default timeout is 5s. This command invokes an alignment test by probing adjacent wireless devices & records MAC addresses & signal strength of responses it receives. By using “show dot11 antenna-alignment” command you can see last 10 devices responded to this probe. Clients will deassociate while doing this testing & automatically reassociate to repeater.Here is output of these command in my repeater AP.
AAP3#dot11 dot11Radio 0 antenna-alignment timeout 3
Type escape sequence "Control ^" to abort.
*Mar 1 01:22:03.435: %DOT11-6-DISASSOC: Interface Dot11Radio0, Deauthenticating Station 001b.d458.e61a
Response from 001b.2a30.48b0 Signal -38 dBm
Response from 001b.2a30.48b0 Signal -13 dBm
Response from 001b.2a30.48b0 Signal -13 dBm
Response from 001b.2a30.48b0 Signal -37 dBm
Response from 001b.2a30.48b0 Signal -37 dBm
AAP3#
Response from 001b.2a30.48b0 Signal -14 dBm
Response from 001b.2a30.48b0 Signal -14 dBm
Response from 001b.2a30.48b0 Signal -13 dBm
Response from 001b.2a30.48b0 Signal -13 dBm
Response from 001b.2a30.48b0 Signal -13 dBm
Response from 001b.2a30.48b0 Signal -13 dBm
*Mar 1 01:22:06.623: %DOT11-4-UPLINK_ESTABLISHED: Interface Dot11Radio0, Associated To AP AAP1 001b.2a30.48b0 [None]
*Mar 1 01:22:06.903: %DOT11-6-DISASSOC: Interface Dot11Radio1, Deauthenticating Station 0022.fa94.6858 Reason: Sending station has left the BSS
*Mar 1 01:22:06.907: %DOT11-6-ASSOC: Interface Dot11Radio1, Station AAP3 0022.fa94.6858 Associated KEY_MGMT[NONE]
If you want to lock the root APs where repeater should associate to you can use “Parent [1-4] mac-address [timeout]” command under radio interface of repeater.Upto 4 parents mac addresses you can add. In my case I have single root (parent mac address can verify from above alignment test). Timeout value in seconds determine how long repeater attempts to associate to a parent AP before trying the next parent in the list. Here is the config line in my example.
interface Dot11Radio0
parent 1 001b.2a30.48b0
Next step is to add security to these sorts of deployment. I need to understand more about different type of security method prior to apply those configurations.
Related Posts
1. Lightweight to Autonomous (vice versa) Conversion
2. Multiple SSID Config on Autonomous AP
3. Autonomous AP – Wireless Bridges
4. WorkGroup Bridge – WGB Configurations
